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1 Introduction
Welcome to Release 1.0 of the Teradici PCoIP® Software Clients.

Teradici PCoIP® Software Clients, also referred to as Teradici PCoIP Clients, are
applications for Windows and Mac computers that allow users to establish a PCoIP session
with a remote workstation containing a Teradici PCoIP® Remote Workstation Card. This
release supports the following Teradici PCoIP Clients:

l Teradici PCoIP® Software Client for Windows
l Teradici PCoIP® Software Client for Mac

This guide explains how to install, configure, and use these software clients. It includes
details about the system requirements for client and host platforms and where you can find
the Teradici PCoIP Client log files.

1.1 Audience
This guide is intended for administrators who are responsible for setting up Teradici
PCoIP® Software Clients.
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2 System Requirements
In this release, Teradici PCoIP® Software Clients are supported on the client and host
platforms listed below.

To download the clients, log in to the Teradici Support Center, click the Products link at the
top of the page, and then click the Remote Workstation Solutions link. The zipped
installation files are located in the PCoIP Client Software section.

2.1 Client Platforms
Teradici PCoIP Clients can be installed on laptops and desktop computers running the
following operating systems:

l Windows 8 (64 bit)
l Windows 7 (64 bit)
l Windows 7 (32 bit)
l Windows XP (32 bit)
l Mac OS X Mountain Lion (10.8)

2.2 Host Platforms
Teradici PCoIP Clients support TERA22x0 and TERA1202 Teradici PCoIP® Remote
Workstation Cards running firmware release 4.1.0 or later.

The following host workstation operating systems are supported:

l Windows 7 (64 bit)
l Windows XP (64 bit)
l Linux CentOS (64 bit)

Note: In this release, the Teradici PCoIP® Software Client for Linux has been tested
with CentOS version 5.6 and 6.4, but may be compatible with additional Linux
distributions. Please see the Teradici Support Center for the most recent information on
supported Linux distributions.

2.2.1 Remote Workstation Configuration
Certain prerequisites must be in place before you can connect to a Teradici PCoIP® Remote
Workstation Card using a Teradici PCoIP Client. These requirements are explained below
along with references to further information.

Remote Workstation Software Requirements

The remote workstation must have the following software installed:

l Windows workstations: PCoIP Host Software for Windows, version 4.0.10
l Linux workstations: PCoIP Host Software for Linux, version 4.1.6
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To download this software, log in to the Teradici Support Center, click the Products link at
the top of the page, and then click the Remote Workstation Solutions link. The zipped
installation files are located in the PCoIP Host Software section.

For instructions on how to install and configure this software, please refer to the following
documentation:

l Windows hosts: "PCoIP® Host Software for Windows User Guide" (TER1008001)
l Linux hosts: "PCoIP® Host Software for Linux User Guide" (TER1104006)

To download these guides, log in to the Teradici Support Center and click the Doc Center
link at the top of the page. The guides are located in the Remote workstation > PCoIP
Host Software section.

Graphics Card Settings for Windows and Linux Workstations

If the graphics card (GPU) on the remote workstation supports temporal dithering, this
feature must be disabled before establishing a PCoIP session. Otherwise, blurriness, heavy
packet loss, and high CPU usage will occur on the PC running the client during a PCoIP
session.

The Windows Nvidia driver does not enable dithering by default, but most ATI drivers do.
For more information, please see Knowledge Base support topic 15134-207 on the Teradici
Support Center.

Display Settings for Windows and Linux Workstations

This release supports only a single monitor. On the remote workstation, this means that you
can have only a single cable connecting the GPU and the Teradici PCoIP® Remote
Workstation Card.

To set up the GPU and card connection:

1. Using the appropriate cable, connect the lowest number GPU port (DisplayPort or
DVI) to the first port on the card.

2. If any other GPU ports are connected to card ports, disconnect them.
3. If you have made changes to these cabling connections during a PCoIP session, close

the session and reboot the workstation. You can then initiate a new session.
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3 Installing/Uninstalling Teradici PCoIP Software
Clients
This section explains how to install and uninstall the following Teradici PCoIP Clients:

l Teradici PCoIP® Software Client for Windows
l Installing from the Windows Installation Wizard
l Installing from the Windows Command Line
l Uninstalling the Teradici PCoIP® Software Client for Windows

l Teradici PCoIP® Software Client for Mac
l Installing the Teradici PCoIP® Software Client for Mac
l Uninstalling the Teradici PCoIP® Software Client for Mac

3.1 Prerequisites
Before installing a Teradici PCoIP Client:

1. Log in as administrator to the local machine or virtual desktop on which you will
install the program. The installation requires administrator privileges.

2. For best results, close all open applications before beginning the installation.

3.2 Teradici PCoIP® Software Client for Windows

3.2.1 Installing from the Windows Installation Wizard
1. Copy the Teradici PCoIP Client installer executable (PCoIP_Client_installer.exe) to

your local PC or virtual desktop.
2. Double-click the file to begin installation.
3. Select your desired language.

4. Click OK and then Next to launch the installation wizard.
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5. Accept the license agreement by clicking I Agree.

6. Use the Browse button to select the folder in which to install the Teradici PCoIP
Client or accept the default, and then click Install.
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7. If you do not have the latest Microsoft Visual C++ Redistributable package installed
on your machine, the following wizard appears to install the necessary runtime
libraries. Click Next.

8. Enable I have read and accept the license terms, and then click Install.
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9. Click Finish to exit the Microsoft setup wizard.

10. If desired, enable Create Desktop Shortcut, and then click Finish to exit the setup
wizard.
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11. If you have created a desktop shortcut, the following icon will appear on your desktop:

3.2.2 Installing from the Windows Command Line
You can also perform a silent installation of the Teradici PCoIP Client by typing the
following at the command-line prompt:

<location>\PCoIP_Client_installer.exe /S

where <location> is the full path to the folder containing the Teradici PCoIP Client installer.

Note: All default options are used for the silent installation. For example, a desktop shortcut
will not be created.

3.2.3 Uninstalling the Teradici PCoIP® Software Client for Windows
1. On the Windows desktop, navigate to Start > Control Panel > Programs and

Features.
2. Select PCoIP Client in the program list.
3. Click Uninstall/Change.
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3.3 Teradici PCoIP® Software Client for Mac

3.3.1 Installing the Teradici PCoIP® Software Client for Mac
1. Copy the Teradici PCoIP Client disk image file (PCoIPClient.dmg) to your Mac

desktop.
2. Double-click the file to mount the volume.
3. Accept the license agreement by clicking the Agree button.

4. In the PCoIPClient volume window, drag the PCoIPClient icon into the
Applications folder icon to install the program.
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5. If desired, you can also create an alias from this window:
a. Double-click on the Applications folder icon to open the folder.
b. Right-click on the PCoIPClient application in the list of applications, and then

selectMake Alias from the popup menu.
c. Drag the alias to your desktop or Dock.

6. To eject the volume when you are finished, drag it to the trash.

3.3.2 Uninstalling the Teradici PCoIP® Software Client for Mac
Simply navigate to the Applications folder and drag the PCoIPClient program to the trash.
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4 Using Teradici PCoIP Software Clients
This section explains how to use Teradici PCoIP Clients to connect to a Teradici PCoIP®
Remote Workstation Card, and how to configure a client to save your connection details.

For the current release, the following limitations apply:

l Using a connection broker to connect to a workstation is not supported.
l PCoIP sessions between a Teradici PCoIP® Software Client for Windows and a remote
Windows workstation do not support the Ctrl+Alt+Delete command sequence. Before
connecting using this client, make sure you are already logged on to the workstation and
the screen is not locked. If your Windows workstation screen is locked or you are logged
off, use a Teradici PCoIP® Zero Client to log back on before continuing with the
following instructions.

Note: When a session is first connected, it takes a few seconds before you can take control
of the mouse. This is normal behavior.

4.1 Connecting to a Teradici PCoIP® Remote Workstation
Card
You can use a Teradici PCoIP Client to connect to a workstation either from the Teradici
PCoIP Client GUI or from a command line.

4.1.1 Connecting Using the Teradici PCoIP Client GUI
1. Double-click the PCoIP Client desktop icon, alias, or program file (pcoip_client.exe

for Windows or PCoIPClient for Mac) to launch the application.
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2. In the Workstation Address text box, enter the fully qualified host name or IP
address of the Teradici PCoIP® Remote Workstation Card installed in the remote
workstation.

3. Optional: In the Connection Name text box, enter a name for your connection. This
field accepts any UTF-8 Unicode character.
Note: This name will be saved so that the next time you want to connect to this host,
you only need to click the saved connection name.
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4. Click the CONNECT button.

Saved Connections

If you have entered a connection name for a host, the Teradici PCoIP Client automatically
saves the connection details.

1. To reconnect, simply click the button for the saved connection. The button label
displays the connection name you assigned when you configured the connection.
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2. To see the IP address, hover your mouse over the saved connection.

3. To rename or delete a saved connection, click the configure button on the right, and
then select the desired option from the popup menu.

New Connections

To connect to a different host:
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1. Click the NEW CONNECTION button.
2. Enter the workstation address and an optional connection name.

3. Click the CONNECT button to connect, or the BACK button to return to the previous
menu without connecting or saving the connection.

4. If you have saved multiple connections, simply click on the desired one to reconnect.
The example below shows three saved connections.
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4.1.2 Connecting Using the Command Line
To connect to a Teradici PCoIP® Remote Workstation Card by launching the Teradici
PCoIP Client from the Windows or Mac OS X command line:

1. Change to the directory where the Teradici PCoIP Client is installed. The default
locations are listed below:
l Windows: C:\Program Files (x86)\Teradici\PCoIP Client\bin
l Mac OS X: /Applications/PCoIPClient.app/Contents/MacOS

2. Type the following command at the prompt:
l Windows: pcoip_client -b <fully qualified host name or IP address of host card>
l Mac OS X: ./pcoip_client -b <fully qualified host name or IP address of host
card>

To see a list of all pcoip_client command parameters, type the following at the prompt:

l Windows: pcoip_client --help
l Mac OS X: ./pcoip_client --help

4.2 Changing the Teradici PCoIP Client Window Mode
The Teradici PCoIP Client window can be displayed in full-screen mode or windowed
mode. Full-screen is the recommended mode to use for best results.

Note: In windowed mode, the Teradici PCoIP Client window must be sized to at least the
minimum resolution supported by the host desktop.
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You can toggle between windowed and full-screen modes using the following key sequence:

l Windows: Ctrl+Alt+Enter
l Mac OS X: option+command+return

When you are in windowed mode from either client, you can also use the View > Show
Fullscreen menu to enter full-screen mode.

Note: Maximizing the window does not put the Teradici PCoIP Client window into full-
screen mode.

4.3 Checking the Software Release
The Teradici PCoIP Client GUI contains an About button in the lower left area of the
window. Click this button to display the Teradici PCoIP Client software release version.
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You can also display the software release version during a PCoIP session from the Teradici
PCoIP Client GUI.

If you have connected using the Teradici PCoIP Client for Windows, select the Help >
About menu.

If you have connected from the Teradici PCoIP Client for Mac, select the Teradici PCoIP
Client > About Teradici PCoIP Client window.
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4.4 Disconnecting a PCoIP Session
You can disconnect your session and close the Teradici PCoIP Client window in the
following ways:

Disconnecting from the Teradici PCoIP Client for Windows

Press Ctrl+Alt+F12 to disconnect your session. If you are in windowed mode, you can also
select the File > Exit menu.
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Disconnecting from the Teradici PCoIP Client for Mac

Press fn+control+option+F12 to disconnect your session. You can also use the Mac OS X
Teradici PCoIP Client > Quit Teradici PCoIP Client menu (or simply press
command+Q).
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5 Troubleshooting
Many problems can be avoided by taking the following measures before you initiate a PCoIP
session between a Teradici PCoIP Client and a Teradici PCoIP® Remote Workstation Card:

l Check that you have the correct firmware version installed on the Teradici PCoIP®
Remote Workstation Card (see Host Platforms) and the correct software version
installed on the remote workstation (see Remote Workstation Software Requirements).

l On the remote workstation, check that the GPU and card are connected correctly (see
Display Settings for Windows and Linux Workstations.

l On the remote workstation, make sure temporal dithering is disabled on the GPU if it
supports this feature. For details, see Graphics Card Settings for Windows and Linux
Workstations).

l For PCoIP sessions between a Teradici PCoIP® Software Client for Windows and a
Windows Teradici PCoIP® Remote Workstation Card, make sure you are already logged
on to the workstation and the screen is not locked before starting the session. If
necessary, use a Teradici PCoIP® Zero Client to log on to the workstation or to unlock
the screen. You can then connect to the workstation using the Teradici PCoIP® Software
Client for Windows.

For information about these and other issues, please see "Teradici PCoIP® Software Clients
Release Notes (TER1301002).

If you experience a problem and require customer support, please log in to the Teradici
Support Center and submit a trouble ticket. To help engineers analyze the problem, attach as
much relevant information as you can, such as screen shots and Teradici PCoIP Client log
files.

5.1 Teradici PCoIP Client Log Files
The Teradici PCoIP Client logs are text files that contain system and session information
about your connection, and are therefore useful for troubleshooting problems. A new log file
is created each time you use a Teradici PCoIP Client to initiate a PCoIP session.

File names for Teradici PCoIP Client logs always begin with pcoip_client_, followed by the
date the log was created, a unique identifier, and a .txt extension.

The figure below shows some sample entries in a Teradici PCoIP Client log file.
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5.1.1 Locating Teradici PCoIP Client for Windows Log Files
For computers running Windows, you can access Teradici PCoIP Client log files as follows:

1. Open a Windows Explorer window.
2. Use the address bar at the top of the Explorer window to navigate to the logs:

l For Windows 7 and Windows 8 (64 bit), navigate to the following folder:
C:\Users\<user_name>\AppData\Local\teradici\PCoIPClient\logs

l For Windows XP, type the following path in the address bar:
C:\Documents and Settings\<user_name>\Local Settings\application
data\Teradici\PCoIPClient\logs

3. Copy and paste the file to another location, or double-click it to open the file and
display its contents.

5.1.2 Locating Teradici PCoIP Client for Mac Log Files
On a Mac computer, Teradici PCoIP Client log files are located within the user's Home
Library folder, which is hidden by default. The recommended way to access Home Library
files is to use the Mac OS X Console.

1. To open the Console, go to the Applications > Utilities folder, and then double-click
Console.

2. In the FILES section of the Log List pane on the left, navigate to the following folder:
~/Library/Logs/Teradici/PCoIPClient

3. Select the desired log file to view its contents in the main pane.
4. To copy the contents:

a. Click anywhere in the log contents, and then select Edit > Select All.
b. Select Edit > Copy.
c. Paste the contents into an email or text file.

You can also display log files in a Mac OS X terminal window.

1. To open a terminal window, go to the Applications > Utilities folder, and then double-
click Terminal.
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2. Navigate to the Teradici PCoIP Client log folder by typing the following command at
the command line prompt:
cd ~/Library/Logs/Teradici/PCoIPClient

3. Type ls to display the list of log files.
4. To view the contents of a file in a read-only editor, type the following command:

view <file_name>
Note: Rather than typing a long file name into the command, you can select the file,
press command+C to copy it, then paste the name using command+V.

5. To exit the editor, type the following command:
:q
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Glossary of Definitions

TER1307002 Issue 1 28

Teradici PCoIP® Software Clients User Guide

DisplayPort
A type of digital video interface
used in 2nd generation Teradici
PCoIP Remote Workstation Cards
(miniDP), 2nd generation Teradici
PCoIP Zero Clients, and also in
some graphics cards.

DVI
Digital Visual Interface. A type of
digital video interface used in 1st
generation Teradici PCoIP Remote
Workstation Cards and Teradici
PCoIP Zero Clients, some 2nd gen-
eration Teradici PCoIP Work-
station Cards and Teradici PCoIP
Zero Clients, and also in some
graphics cards.

GPU
Graphics Processing Unit. The
graphics card on a PC or work-
station.

log files
Text files that contain system and
session information about each
PCoIP session. Teradici PCoIP
Software Client log files begin
with "pcoip_client_", followed by
the date the log was created, a
unique identifier, and a ".txt" exten-
sion.

PCoIP Host Software for Linux
A software package on a host
Linux PC or workstation that
allows administrators to manage
some Teradici PCoIP Remote
Workstation Card features used by
the Teradici PCoIP Software Cli-
ents.

PCoIP Host Software for Windows
A software package on a host Win-
dows PC or workstation that
allows administrators to manage
some Teradici PCoIP Remote
Workstation Card features used by
the Teradici PCoIP Software Cli-
ents.

TERA1202
First-generation Teradici processor
supporting Teradici PCoIP Remote
Workstation Card functionality.
TERA1202 cards support two dis-
plays at a resolution of 1920x1200.

TERA2220
Second-generation Teradici pro-
cessor supporting Teradici PCoIP
Remote Workstation Card func-
tionality. TERA2220 cards support
two displays at a resolution of
1920x1200 or one display at a res-
olution of 2560x1600.
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TERA2240
Second-generation Teradici pro-
cessor supporting Teradici PCoIP
Remote Workstation Card func-
tionality. TERA2240 cards support
four displays at a resolution of
1920x1200 or two displays at a res-
olution of 2560x1600.

Teradici PCoIP host
The host or server side of a PCoIP
system. In this release, Teradici
PCoIP Software Clients support
connections to remote Windows
and Linux workstation hosts con-
taining Teradici PCoIP Remote
Workstation Cards.

Teradici PCoIP Software Clients
Applications for Windows and
Mac computers that allow users to
establish PCoIP sessions with
Teradici PCoIP Remote Work-
station Cards.
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